Compatibilité ORBISGIS 4.1 et 4.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Compatibilité ORBISGIS 4.1 et 4.0

Anne
Bonjour,

Suite à l'utilisation de la nouvelle version d'OrbisGIS : orbisgis-dist-4.1.0-SNAPSHOT-2014-06-25, je n'arrive plus à lancer la version précedente orbisgis-dist-4.0-SNAPSHOT (03/06/2013) compatible avec mes script SQL et BeanShell et les cartographies déjà produites. Concrètement, lorsque je tente de lancer Orbisgis 4.0, orbisgis.sh > Lancer dans un terminal, le lancement Orbisgis apparaît et le terminal se lance, puis tout s'annule sans que je puisse lire les messages affichés dans le terminal.

Avez-vous déjà rencontrez ce type de problème ?

Merci pour votre aide ;-)

Anne
Reply | Threaded
Open this post in threaded view
|

Re: Compatibilité ORBISGIS 4.1 et 4.0

Anne
Bonjour à nouveau,

Pour avoir mené l'enquête, voici quelques précisions :
Orbisgis 4.0 tente d'ouvrir mon workspace par défaut mais n'y arrive pas.
C'est ce même workspace que j'ai ouvert avec Orbisgis 4.1.

Est-ce que l'ouverture d'un workspace avec Orbisgis 4.1, sans modifications car c'était juste pour tester, le rend incompatible avec Orbisgis 4.0 ?

Dans ce cas, comment modifier l'ouverture par défaut du workspace incompatible ?
Et comment récupérer les traitements ? Car même l'ouverture du workspace dans Orbisgis 4.1 génère des erreurs, il ne trouve pas les tables sources.

J'espère que ces petite précisions vous seront utiles.
Encore merci par avance,

Anne
Reply | Threaded
Open this post in threaded view
|

Re: Compatibilité ORBISGIS 4.1 et 4.0

agouge
Bonjour Anne,
 
Je pense pouvoir répondre à tes questions en disant que les workspaces OrbisGIS 4.0 et les workspaces OrbisGIS 4.1 sont complètement incompatibles, et ce dû au fait qu'entre les deux versions nous avons remplacé le moteur SQL GDMS par H2. Une base de données GDMS est incompatible avec une base de données H2.

Un tel changement implique des différences d'implémentation énormes qui nous ont obligés de casser la compatibilité entre les deux workspaces. Par conséquent, il ne faudrait pas mélanger des workspaces 4.0 et des workspaces 4.1. (Peut-être aurait-il était plus judicieux de l'appeler OrbisGIS 5.0 au lieu de 4.1.)

Par contre, la syntaxe des scripts devrait rester en grande partie la même, avec quelques exceptions.

J'espère avoir répondu à tes questions, mais n'hésite pas s'il te faut plus d'aide ou de précisions.

Bien cordialement,
Adam