Aprés synchro impossible de démmarrer orbisGis

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Aprés synchro impossible de démmarrer orbisGis

Nicolas F.
Administrator
J'ai fait une synchro ce matin. Depuis je ne peut plus lancer orbisGis.

L'erreur est la suivante

Exception in thread "main" java.lang.Exception: java.lang.NullPointerException
        at org.orbisgis.core.Main.init(Main.java:151)
        at org.orbisgis.core.Main.main(Main.java:88)
Caused by: java.lang.NullPointerException
        at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:433)
        at org.apache.log4j.PropertyConfigurator.configure(PropertyConfigurator.java:336)
        at org.orbisgis.core.Main.initProperties(Main.java:179)
        at org.orbisgis.core.Main.init(Main.java:112)
        ... 1 more



En fait l'appel suivant retourne null
Main.class.getResource("log4j.properties")

Une solution ?

merci
Reply | Threaded
Open this post in threaded view
|

Re: Aprés synchro impossible de démmarrer orbisGis

albacore
Bonjour Nicolas,

Bizard ce fichier est présent sur le svn.
As tu le fichier
orbisgis-core/src/main/resources/org/orbisgis/core/log4j.properties?
S'il n'y ait pas fait un update depuis le svn.

S'il tu as bien ce fichier, je pense que ce fichier manque dans le
répartore de compilation /target.
Essaye un "clean all project" dans eclipse. (Project -> clean all projects)

Pierre-yves
Pierre-yves.
Reply | Threaded
Open this post in threaded view
|

Re: Aprés synchro impossible de démmarrer orbisGis

Nicolas F.
Administrator
Bonjour,

merci pour l'astuce, le clean all a résolu le problème.

-Nicolas